Eventide H9 and Pedal Power 2 +

General discussion and tech talk about the industry standard Pedal Power line of power supplies.
Rez
Posts: 236
Joined: Thu Sep 01, 2011 10:31 am

Re: Eventide H9 and Pedal Power 2 +

Post by Rez » Thu Aug 09, 2018 5:21 pm

Ah... that's good news. Then, likely it's a cable and not the supply itself. Maybe test first the black/red ended cable: it should have continuity from sleeve on one side to center on the other side (and vise versa). And, there should not be continuity from center-to-center or sleeve-to-sleeve.

Also, maybe give us a call, (707) 545-0600 and we'll talk you through it.
Cheers,
Ben Resnick
Voodoo Lab - Tech Support

jeff_g
Posts: 33
Joined: Wed May 20, 2009 6:59 am

Re: Eventide H9 and Pedal Power 2 +

Post by jeff_g » Fri Aug 10, 2018 9:25 am

So, the second doubler showed up in the mail today, and just for the heck of it, I tried it. And it works. Strange.

jeff_g
Posts: 33
Joined: Wed May 20, 2009 6:59 am

Re: Eventide H9 and Pedal Power 2 +

Post by jeff_g » Fri Aug 10, 2018 11:25 am

So now I have a new problem, hahaha. Since the H9 is now taking up 5 and 6, I don’t have any high output power for the Digitech FreqOut. Their website says its power consumption is 2.1 Watts (235 mA typical @ 9 VDC)...I think I might be out of luck on this one, since doubling the other sockets would only get me to 200mA. Any advice? I’m already using the courtesy outlet for another adapter, unfortunately.

Rez
Posts: 236
Joined: Thu Sep 01, 2011 10:31 am

Re: Eventide H9 and Pedal Power 2 +

Post by Rez » Fri Aug 10, 2018 11:29 am

You can instead use your H9, setup:

To power the H9 with Pedal Power 2 Plus, use a Current Doubler Adapter in Pedal Power 2 Plus outputs 4 and 5 (or 6 and 7), DIP switches set normal and the reverse polarity cable (red/black connectors partPPL6) supplied w/ your Pedal Power 2 Plus.

That works equally well and hmm... maybe the first doubler is intermittent/faulty but glad, you've got it worked out now.


Cheers!
Cheers,
Ben Resnick
Voodoo Lab - Tech Support

jeff_g
Posts: 33
Joined: Wed May 20, 2009 6:59 am

Re: Eventide H9 and Pedal Power 2 +

Post by jeff_g » Fri Aug 10, 2018 1:44 pm

I’ll try that when I get to my gig later - thanks Ben. You’re awesome - have a great weekend! I’ll let you know if it works ASAP.

jeff_g
Posts: 33
Joined: Wed May 20, 2009 6:59 am

Re: Eventide H9 and Pedal Power 2 +

Post by jeff_g » Sat Aug 11, 2018 2:42 pm

Took your advice and both pedals are working, thanks so much! I’ve got 5 other pedals on the board...one is powered by the courtesy outlet, but it seems that of the four plugged into the PP2+, one of the four will not power up. Is it possible that I’ve just maxed out the draw? They’re all “standard drawing” pedals as far as I know...one is just a true bypass loop that just needs power for the status LED

Rez
Posts: 236
Joined: Thu Sep 01, 2011 10:31 am

Re: Eventide H9 and Pedal Power 2 +

Post by Rez » Mon Aug 13, 2018 3:46 pm

Perhaps...

Exactly which pedals (make, model) are being powered and from which specific outputs?
Cheers,
Ben Resnick
Voodoo Lab - Tech Support

Post Reply