Page 1 of 1

Pedal Power 2 Plus Shutting Down

Posted: Wed Oct 09, 2019 9:43 am
by tdsaxman
Hi, I’ve been having an issue lately where my pedal power 2 plus turns off randomly while in use. I haven’t added any new pedals or made any changes for a few months and this just started happening. The chain on my board is:

Shure Wireless Receiver* (I’m a saxophonist so my mic runs into this then into the board)
3leaf audio proton
JHS Charlie Brown V4
TC Quintessence Harmonizer
EHX Micro POG
TC Flashback Delay
EQD Avalanche Run Delay/Reverb*
MXR 10 band EQ*

*=these pedals are being powered with their adapters from a small power strip plugged into the back of the pedal power 2+.

Everything else seems to be powered by the appropriate outlets in the pedal power. The micro POG requires 9v450mA so I have a current doubler plugged into 5&6 with the DIP switches in the normal position giving it 500mA. Everything else is 9v100mA or less so with the DIP switches in the normal positions I have those other pedals in outlets 3,4,6&7.

Like I said, the board has been in this configuration for a few months now and everything has been working well. Part of me thinks it may be my IEC cable so I’m going to try a different one. Otherwise, I’m not sure what the issue could be. Any thoughts and suggestions on the matter are greatly appreciated.

Thanks.

Re: Pedal Power 2 Plus Shutting Down

Posted: Wed Oct 09, 2019 9:52 am
by JohnClark
When the problem occurs, does everything drop out including the pedals on the power strip from the Courtesy Outlet, or do only the pedals powered directly from the Pedal Power drop out?

If it's everything, I would suspect the IEC cable or its connection to the Pedal Power AC Input.

If it's just the pedals on the Pedal Power... well, I don't know what I would think if that is the case ;)

Re: Pedal Power 2 Plus Shutting Down

Posted: Wed Oct 09, 2019 10:40 am
by tdsaxman
Yes, everything connected to the Pedal Power shuts off. I'll try a different IEC cable and see if that helps.