Voodoo Power Supplies and Voltage Regulator ?????

General discussion and tech talk about the industry standard Pedal Power line of power supplies.
Post Reply
planethood
Posts: 84
Joined: Sat Jan 29, 2011 7:39 am

Voodoo Power Supplies and Voltage Regulator ?????

Post by planethood » Sat Mar 02, 2013 6:06 pm

I have a very interesting and mind boggling issue. I have a PP2+ and a Pedal Power AC. I also have two products from Furman: a P-1800 PFR (power conditioner) and P-1800 AR (voltage regulator). When I plug the Voodoo supplies into the P-1800 PFR, they make virtually no noise. However, when I plug them into the P-1800 AR, they hum pretty bad.

I have taken both Furman products out of the rack and it hasn't made a difference. Then, I plugged them into different outlets in my house. Still no difference....quiet as a mouse on the power conditioner and humming like a bee on the voltage regulator.

I'm stumped....

Currently, I have the voltage regulator in a top rack and the power conditioner in the bottom rack. All of my effects units are in the top rack (on the regulator) and my preamp/poweramp are in the bottom rack (on the power conditioner). According to Furman, I need to have the power conditoner in-line from the wall first and plug the voltage regulator into that.....so....I need to be able to have the Voodoo units on the voltage regulator.

Any ideas? I'm thinking this one's a 'stumper' for the great John Clark!!!! (yes, that is a challenge!)

JohnClark
Posts: 7465
Joined: Tue May 05, 2009 2:33 pm
Location: The Lab

Re: Voodoo Power Supplies and Voltage Regulator ?????

Post by JohnClark » Wed Mar 06, 2013 11:15 am

That is strange.

What is the simplest setup that still shows the problem?
------------------====Cheers!====------------------
Image
---------==Voodoo Lab Magician & Tech==---------

planethood
Posts: 84
Joined: Sat Jan 29, 2011 7:39 am

Re: Voodoo Power Supplies and Voltage Regulator ?????

Post by planethood » Sat Mar 09, 2013 12:25 pm

P-1800 AR (voltage regulator) + Pedal Power AC = more buzzy PPAC
P-1800 PFR (power conditioner) + Pedal Power AC = very little buzz PPAC

Same goes for the PP2+.

I bought some shorter power chords off amazon.com to use for both devices. Is it possible that I bought the wrong type of power chord? They both power up fine.

I can't find my original power chords for both units to see if it makes a difference. Is there something specific I should look for with the power chord (e.g. 30 celsius, 14awg, etc).

The only thing I can think of is the way the units are designed to regulate power within them? Maybe it has something to do with the way power is fed to them from the voltage regulator, instead of the power conditioner.

Post Reply