Location pop switching issues

Q & A for building and interfacing your rack gear with Ground Control Pro and GCX-based systems.
Post Reply
Jose M
Posts: 5
Joined: Tue Nov 21, 2017 5:58 am

Location pop switching issues

Post by Jose M » Mon Mar 21, 2022 8:56 am

Hi, everyone. Hope you all are fine.

I have a rack system with 2 ground control Pro connected (one for presets , the other for IA) and 3 GCX.

After several years with no troubles, significant pop noise related to switching appeared. I don´t remember changing anything special.

I have tested each pedal separtely in only one gcx, always with the same result from loop 1 regardless the pedal and the GCX Unit. I have changed instrument, line and MIDI cables.

The noise appears with just one pedal (any of them) without using the other loops and regardless the loop used.

I also have tested:

Guitar In- Guitar out - Loop (1 to 8, each of them only one used) IN and Loop (1 to 8, respectively each of them) OUT to preamp or amp without any connected pedal in the loop.

Feed thru - Feed thru - Loop (1 to 8, each of them only one used) IN and Loop (1 to 8, respectively each of them) OUT to preamp or amp without any connected pedal in the loop.

Always the same noise

I have experimented with both GCP separatedly (when pressing different IA or changing presets affecting different loops) and also have this pop noise.

The GCP and GCX are powered with AC 9V adaptors (2000 mA).

Any idea where the problem might be ?

Thank you very much in advance

Jose M.

Post Reply