loud noise, buzzing

Q & A for building and interfacing your rack gear with Ground Control Pro and GCX-based systems.
Post Reply
shalai85
Posts: 2
Joined: Fri Jun 12, 2009 5:14 pm

loud noise, buzzing

Post by shalai85 » Fri Jun 12, 2009 5:44 pm

i need some help, i dont know what i'm doing wrong.

ive got my gcx set up just the way i like it wit my mesa mark iv, its quiet it changes the channels, everything is good. however i am trying to run a second amp. a randall mts.

when i plug the randall in both amps buzz really loudly. im going into the guitar in jack on the front pannel and comming out of the guitar out and feed thru jacks on the back pannel to the amps. (as the manual suggests.)

i changed from the guitar in jack and used the feed thru on the front pannel and th buzzing went away, but only one amp worked fine and the other seemed to sound broken.

when i unplug from the inputs of the amps the buzzing goes away and when i plug into either amp on its own it is quiet. everything is powered with a power conditioner. it seems to be comming from when i split the signal with the gcx that is creating the buzz.

any help will be greatly appreciated. :)

voodoo lab rules.

John01W
Posts: 55
Joined: Thu May 28, 2009 10:47 am

Re: loud noise, buzzing

Post by John01W » Sat Jun 13, 2009 10:50 pm

You have a ground loop from connecting to the inputs of 2 amps. What you need is an isolation transformer before one of the inputs. You can get a lehle p-split ii to do exactly that....cheap and very high quality.

I'm doing the same thing(pt100 and a 3+ preamp). Any time you split your guitar signal to feed the inputs of 2 amps simultaneously you're gonna get a ground loop.

shalai85
Posts: 2
Joined: Fri Jun 12, 2009 5:14 pm

Re: loud noise, buzzing

Post by shalai85 » Mon Jun 15, 2009 12:51 am

mate, your a legend. thanks for your help. ill get one asap.

cheers. :D

Post Reply