hum problems with Dual Recto, GCAS, External swithing

Q & A for building and interfacing your rack gear with Ground Control Pro and GCX-based systems.
Post Reply
Christoffer.N
Posts: 9
Joined: Tue Jun 14, 2016 9:43 am

hum problems with Dual Recto, GCAS, External swithing

Post by Christoffer.N » Wed Jul 13, 2016 4:56 am

I have a problem with ground hum from my recto!?

I'm using the external switching jacks to control channel 2 and 3 with my GCAS.
It doesn't apply when I'm on the clean channel!

it doesn't do any hum when I using the Rectifier foot switch either.
Only when i using the external switching jacks to my GCAS.

I have seen a couple of topics: one is that you could isolate your rack with humfrees so i tried but its the same.
someone said that you need to use the Y-Kabel!? haven't tried it yet thou.

(this topic is on the boogie board as well)

any thought!?

Kind regards
Chris!

JohnClark
Posts: 7462
Joined: Tue May 05, 2009 2:33 pm
Location: The Lab

Re: hum problems with Dual Recto, GCAS, External swithing

Post by JohnClark » Wed Jul 13, 2016 9:27 am

GCAS? Do you perhaps mean GCX?

If you are using a GCX, make sure you are using only the OUT/N.O. jack for the two loops controlling the Amp Channels. Make sure no other cables are connected to the other jacks on these loops.

When you switch these Amp Channels, are you also switching anything else at the same time?
------------------====Cheers!====------------------
Image
---------==Voodoo Lab Magician & Tech==---------

Christoffer.N
Posts: 9
Joined: Tue Jun 14, 2016 9:43 am

Re: hum problems with Dual Recto, GCAS, External swithing

Post by Christoffer.N » Wed Jul 20, 2016 1:57 am

Yes Sir! ;)

Thats correct! i'm only using the OUT/N.O jacks...

Well not really, just my Boss-NS 2 witch is on all the time.

Kind Regards!
Chris!

JohnClark
Posts: 7462
Joined: Tue May 05, 2009 2:33 pm
Location: The Lab

Re: hum problems with Dual Recto, GCAS, External swithing

Post by JohnClark » Wed Jul 20, 2016 9:55 am

So the only things your GCX is controlling are the noise gate (but the loop is always on) and the two amp channels?
What is the complete signal routing?
Does the noise go away if you leave the GCX connected to the External Switching but eliminate everything else by running the guitar directly to the amp, and having nothing in the amp's FX Loop?

Also, how long are the switching cables?

p.s. (This may have been changed on newer models) You should make sure that the sleeves or outer casing of the cables used on the External Switching jacks are not touching anything else. The "ground" on the External Switching circuit circuit is referenced differently than the chassis or audio ground on these amps and they don't like being connected together.
------------------====Cheers!====------------------
Image
---------==Voodoo Lab Magician & Tech==---------

Christoffer.N
Posts: 9
Joined: Tue Jun 14, 2016 9:43 am

Re: hum problems with Dual Recto, GCAS, External swithing

Post by Christoffer.N » Tue Aug 09, 2016 5:50 am

Hello John!
Sorry for the late answer!

I have been controlling every cable, every port on the GCX and the Power to my pedal etc and different connection methods. When i finally located the source of my problem! It was my Power Conditioner!

The complete signal route is Guitar -> GCX -> BOSS NS 2 -> Pedal 2 -> Pedal 3 -> JC-120 ->Mesa Dual -> External switching...

As you mention if I only used my GCX and the recto. the external switching hum/signal sound were gone!

Any thoughts how to get rid of the problem with my Power conditioner!?

My Rack:

Furman PI-Plus CE
TC Electronic G-Major 2
Rack Drawer ((open)Voodoo lab pedal power 2 plus,boss ns 2,pedal 2,pedal 3)
GCX
GCP

Mesa Dual Recto
JC-120

JohnClark
Posts: 7462
Joined: Tue May 05, 2009 2:33 pm
Location: The Lab

Re: hum problems with Dual Recto, GCAS, External swithing

Post by JohnClark » Tue Aug 09, 2016 2:01 pm

Oh, you never mentioned running two amps before... What happens if you only remove the JC-120?
------------------====Cheers!====------------------
Image
---------==Voodoo Lab Magician & Tech==---------

CAR-15
Posts: 15
Joined: Sat Jan 24, 2015 3:08 pm

Re: hum problems with Dual Recto, GCAS, External swithing

Post by CAR-15 » Thu Aug 11, 2016 11:38 am

I had the same hum problem when running two amps off of the GCX. EBTECH hum eliminator fixed it right up!

Christoffer.N
Posts: 9
Joined: Tue Jun 14, 2016 9:43 am

Re: hum problems with Dual Recto, GCAS, External swithing

Post by Christoffer.N » Sat Aug 13, 2016 10:51 am

If i removed the JC-120 its still ground hum noise.

As I mention before its my power conditioner!

I tried the hole setup but removed the power conditioner and the hum noise disappeared.

I did youtube the ebtech hum eliminator i think thats the answer for me.

Any thoughts on my Furman PI-Plus CE!?



My Rack

Furman PI-Plus CE
TC Electronic G-Major 2
Rack Drawer ((open)Voodoo lab pedal power 2 plus,boss ns 2,pedal 2,pedal 3)
GCX
GCP

Mesa Dual Recto
JC-120

JohnClark
Posts: 7462
Joined: Tue May 05, 2009 2:33 pm
Location: The Lab

Re: hum problems with Dual Recto, GCAS, External swithing

Post by JohnClark » Mon Aug 15, 2016 1:33 pm

I am unsure how your power conditioner could be the cause... but if removing it eliminates the problem, then I suppose you may want to have the power conditioner checked out.

If this rig is quiet when both amps are connected then the Hum eliminator will not do anything for you.
------------------====Cheers!====------------------
Image
---------==Voodoo Lab Magician & Tech==---------

Post Reply