GCP/GCX/Kemper Power Rack - Pedal weirdness

Q & A for building and interfacing your rack gear with Ground Control Pro and GCX-based systems.
JohnClark
Posts: 7092
Joined: Tue May 05, 2009 2:33 pm
Location: The Lab

Re: GCP/GCX/Kemper Power Rack - Pedal weirdness

Post by JohnClark » Tue Oct 24, 2017 10:56 am

v1.12 should be fine for this so no worries there.

As a test, recall any preset that has both expression pedals active. Go into the Preset Edit Mode by pressing and holding the Edit button then use the Select Down button repeatedly to get to the P1 screen. While looking at the P1 screen, rock the pedal connected to P2 to be sure it is not affecting the first three digits on the screen. Then do same thing on the P2 screen but rock the pedal connecte to P1 to be sure it is not affecting the first three digits on the screen.

If the pedals look to work as they should I suppose you could look thru Setup Mode settings to be sure extra things are not turned on... like check under Device Name/Channel that only your Kemper is assigned a MIDI Channel and that the other locations are blank (unless you have added the H9 of course but it should at least be on a different MIDI Channel than the Kemper). Under Expanders make sure that only GCX #1 is On and that the VCA is OFF. Under MIDI make sure the Link Mode is set to None.

Let us know what you find!

neuk01642
Posts: 24
Joined: Thu Sep 28, 2017 2:46 am

Re: GCP/GCX/Kemper Power Rack - Pedal weirdness

Post by neuk01642 » Wed Oct 25, 2017 5:54 am

JohnClark wrote:v1.12 should be fine for this so no worries there.

As a test, recall any preset that has both expression pedals active. Go into the Preset Edit Mode by pressing and holding the Edit button then use the Select Down button repeatedly to get to the P1 screen. While looking at the P1 screen, rock the pedal connected to P2 to be sure it is not affecting the first three digits on the screen. Then do same thing on the P2 screen but rock the pedal connecte to P1 to be sure it is not affecting the first three digits on the screen.

If the pedals look to work as they should I suppose you could look thru Setup Mode settings to be sure extra things are not turned on... like check under Device Name/Channel that only your Kemper is assigned a MIDI Channel and that the other locations are blank (unless you have added the H9 of course but it should at least be on a different MIDI Channel than the Kemper). Under Expanders make sure that only GCX #1 is On and that the VCA is OFF. Under MIDI make sure the Link Mode is set to None.

Let us know what you find!
Thanks John, will check out the things you've listed and get back to you.

Appreciate you taking the time.

Matt

Post Reply